liudmilka19091982
10.04.2020 00:55

Составить программу на делфи и с результатом .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zenix122
03.10.2021 12:43

pascalabc:

program f0rwardirop;

var r, x,y: real;

b: boolean;

begin

  writeln('*   alphaeus is   *');

  write('ok, введите r =');   readln(r);

  write('теперь введите х =');   readln(x);

  write('и, наконец, введите y =');   readln(y);

  if x> =0 then  

      if (x*x+y*y < = r*r) then b: = true else b: =false

    else

      if (abs(x) < =r) and (abs(y) < =r) and (abs(x) < = abs(y)) then b: = true else b: =false;

  if b then   writeln('точка (',x,',',y,') принадлежит закрашенной области')

      else   writeln('точка (',x,',',y,') не принадлежит закрашенной области');

end.

0,0(0 оценок)
Ответ:
ushhahas02828
03.10.2021 12:43

a = input()

print(a[-1:] if int(a) % 2 == 0 else a[-2:-1])

Объяснение:

1) Введем число как строку.

2) Конструкция "действие1 if условие1 else действие2" (она еще называется тернарным оператором) выполняет действие1, если условие1 возвращает True, иначе выполняется действие2. Это уменьшает количество строк кода с четырех до одной.

3) Выражение s[a:b] вернет все символы в строке s в диапазоне [a; b). Выражение s[a:] вернет все символы в строке s от a до конца строки. Если a или b отрицательные, то отсчет будет вестись с конца строки. Выражение s[-1:] вернет все символы в строке, начиная с последнего (т.е., последний символ). Ну а s[-2:-1] вернет все символы с предпоследнего до последнего, исключая последний (т.е., предпоследний символ).

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота