Rabika2018
17.07.2020 14:52

Решить (pascal),составить программу: b-7 1) вычисления значения функции вычисления значения функции y=2*10'5 cos3x-v(x+1) при любых значениях х 2). дано расстояние в сантиметрах. найти число полных метров в нем и сколько это будет в дюймах (1 дюйм=2,54 см) 3) дано трехзначное число. найти: а) число сотен в нем; б)число десятков в нем; в) число единиц в нем; в) сумму его цифр.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Diglir
27.08.2022 02:52

Алгоритм быстрой сортировки подразумевает следующее.

В качестве опорного элемента выбирается какой-то из элементов отрезка массива (я в коде буду брать самый левый). Затем все элементы массива делятся на две части: все, кто меньше опорного элемента, должны стоять левее его, все, кто больше, правее. Затем всё продолжается для двух подмассивов из чисел, больших опорного элемента, и чисел, меньших опорного элемента. Процесс останавливается, если в том отрезке массива, который требуется отсортировать, один или ноль элементов.

Можно предложить такую реализацию:

def QS(A, st, end):

   if end <= st:

       return

   base = A[st]

   less = [elem for elem in A[st:end + 1] if elem < base]

   equal = sum(elem == base for elem in A[st:end + 1])

   greater = [elem for elem in A[st:end + 1] if elem > base]

   A[st:st + len(less)] = less

   A[st + len(less):st + len(less) + equal] = [base] * equal

   A[st + len(less) + equal:end + 1] = greater

   QS(A, st, st + len(less) - 1)

   QS(A, st + len(less) + equal, end)

Но это всё выглядит не очень в стиле Питона - скорее всего, авторы курса просто бездумно скопировали задание с других языков программирования.

0,0(0 оценок)
Ответ:
MartKsenka
17.12.2020 02:43

# Первый цикл поднимет a на 3, второй и третий на 0, 4-й на 2.

a = 1

for i in range(3):

   a += 1

   '''print(f'[for i in range(3) > RANGE][a = {a}]')'''

print(f'[for i in range(3) > TOTAL][a = {a}]')

a = 1

for i in range(3, 1):

   a += 1

   '''print(f'[for i in range(3, 1) > RANGE][a = {a}]')'''

print(f'[for i in range(3, 1) > TOTAL][a = {a}]')

a = 1

for i in range(1, 3, -1):

   a += 1

   '''print(f'[for i in range(1, 3, -1) > RANGE][a = {a}]')'''

print(f'[for i in range(1, 3, -1) > TOTAL][a = {a}]')

a = 1

for i in range(3, 1, -1):

   a += 1

   '''print(f'[for i in range(3, 1, -1) > RANGE][a = {a}]')'''

print(f'[for i in range(3, 1, -1) > TOTAL][a = {a}]')

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота