Viktoria070804
20.05.2023 16:03

Впрограмме описан одномерный целочисленный массив a, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 21. s: =0; n: =21; for i: = 2 to n do begin s: =s+2*(a[i]-a[i-1]); end; в начале выполнения этого фрагмента в элементе массива с индексом i находилось число i (i = 1, …, 21), т. е. a[1] = 1, a[2] = 2 и т. д. чему будет равно значение переменной s после выполнения данной программы? 1) 20 2) 21 3) 40 4) 42

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Smile460
20.07.2020 16:16
Дополнил код до программы:

var
s: real;
i, n: integer;
A: array [1..21] of real;
begin
s:=0;
n:=21;
for i:= 1 to n do
A[i]:=i;
for i:= 2 to n do
begin
s:=s+2*(A[i]-A[i-1]);
end;
writeln(s);
end.

Результат: 40
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота