MrsVaderr
29.08.2021 17:13

Написать программу в паскале дано трехзначное число х найти сумму его цифр, среднее арифметическое и записать число в обратном порядке.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Vishenka333
20.07.2020 15:12

program n_1;

var m,n,n1,n2,n3,n4:integer;

begin

 writeln('Введите трехзначное натуральное число: ');

 readln(n);

 n1:=n mod 10;

 n2:=(n mod 100) div 10;

 n3:=n div 100;

 m:=n1+n2+n3;

 writeln('Сумма цифр: ',m);

 writeln('Среднее арифметическое: ',m/3:0:5);

 m:=100*n1+10*n2+n3;

 writeln('В обратном порядке: ',m)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота