Katya149555
03.06.2020 02:29

Составьте программу, которая формирует массив из 16 случайных целых цисел от -20 до 20 и находит элементы с нулевыми значениями

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
feyaandkisa
26.05.2020 00:47

var

  a: array [1..16] of integer;  //Массив из 16 целых чисел

  i: integer;

 

begin

  randomize;  

  write('Исходный массив:  ');

  for i:= 1 to 16 do  {Заполняем массив случайными целыми числами от -20 до 20 и распечатываем его}

  begin

    a[i]:= random(40) - 20;

    write(a[i], '  ');

  end;

  writeln;

  write('Элементы с нулевыми значениями:  ');

  for i:= 1 to 16 do  {Распечатываем элементы с нулевыми значениями через точку с запятой}

    if a[i] = 0 then write('a[', i, '] = ', a[i], '; ');

  writeln;

end.

Если все правильно, отметь решение как лучшее)

   

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота