Matthi
21.03.2020 11:08

Написать программу (процедуру), выводящую квадраты чисел от a до b (a,b вводятся с клавиатуры);

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Annkot22
20.07.2020 14:20
И всё-таки, мне кажется, что надо вывести именно полные квадраты чисел в указанном диапазоне, иначе формулировка была бы типа: "Возведите в квадрат все числа в указанном диапазоне". Код на паскале:
var a, b, i, j : integer;
begin
readln(a, b);
for i := a to b do
begin
j := round(sqrt(i));
if j*j = i then writeln(i);
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота