DasyaSay
31.10.2021 06:36

Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов.известно, что в массиве есть хотя бы один нечетный элемент.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
softinator
20.07.2020 11:19
Const
  n = 50;

var
  a: array[1..n] of integer;
  i, min: integer;

begin
  Randomize;
  Writeln('Исходный массив');
  min:=32767;
  for i := 1 to n do
  begin
    a[i] := Random(99)+1;
    Write(a[i]:3);
    if ((a[i] mod 2)<>0) and (min>a[i]) then min:=a[i]
  end;
  Writeln;
  Writeln('Минимальный нечетный элемент равен ',min)
end.

Тестовое решение:
Исходный массив
 24 19 87 17 11 98 74 11 57 42  9 23  3 90 62 61 53 55 63 93 22 50 82 97 26 39 43 26 46 52 13 94 26 98 87 95 43 69 24 41 56 78 22 45 53 45 59 57  3 64
Минимальный нечетный элемент равен 3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота