Войти
Регистрация
Спроси ai-bota
Fansik34324
03.06.2022 06:38
Составьте программу которая вычисляет сумму натуральных чисел на отрезке ( 5, 10 ) с оператора while
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
222111ALEXA111222
27.06.2021 01:56
Написать процедуру, которая получает в качестве первого параметра количество элементов массива MasMax, в качестве второго параметра - значение начального элемента массива,...
madinakhamrayev
08.10.2021 07:02
Определите форматирования, использованные в таблице...
Евгешаточкару2006
16.02.2022 04:16
Определите этимологию слова «мусульманин».?...
Карейка0167
10.02.2021 05:00
Информатика рабочая тетрадь 1 часть босова 8 класс номер решите кто нибудь...
krisrinanovokr
10.11.2020 21:29
Перевести число из двоичной системы в системы с основанием 8, 10, 16. 2) Перевести число из восьмеричной системы в системы с основанием 2, 10, 16. 3) Перевести число из...
Danil200000006
20.11.2022 10:58
3. Выполни соответствие Необходимо выполнить соответствие, указав стрелочкой элемент окна программы Photo-Brush на его определение.Установка параметров нового изображенияОкно...
Студент71653
08.11.2021 15:23
Испаниядағы клубтардын санын есептейтін формула...
sinjay
07.06.2021 05:24
Исполнитель робот Сделайте алгоритм...
ФамилГасанов
14.08.2022 21:04
Рассмотрите следующие фигурs Определите инструменты, с которых были созданы фигуры....
Gurza97
12.01.2023 15:08
Какие действия в программе Paint.net сохраняют нарисованную картинкуАФайл - Создать - Новый файлФайл - Сохранить как - Bписать название картинки - сохранитьПравка - Сохранить...
Ответ:
fanaidap
02.10.2020 10:23
Var n, o: integer;
begin
n:=5;
while (n<>11) do
begin
o:=o+n;
n:=n+1
end;
writeln(o)
end.
0,0
(0 оценок)
Ответ:
sobitlogin
02.10.2020 10:23
#include <conio.h>
#include <iostream>
#include <locale.h>
using namespace std;
int main()
{
setlocale(0,"");
int x_min,x_max;
int Sum;
cout<<"Введите начало отрезка\n";
cin>>x_min;
cout<<"Введите конец отрезка\n";
cin>>x_max;
int temp=x_min;
if(x_min>x_max) //проверяем что бы минимальный элемент не был больше максимального
{
int temp;//буфер
temp=x_min;
x_min=x_max;
x_max=temp;
}
while(x_min<=x_max)
{
Sum+=x_min;
++x_min;
}
cout<<"Сумма натуральных эментов на отрезке ("<<temp<<","<<x_max<<") = "<<Sum<<endl;
return 0;
}
Программа вычисляет отрезок любого элемента и делает проверку на правильность ввода
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота