daryaromanovsk
16.08.2021 01:53

Составьте программу вычисления количеств трёхзначных чисел, у которых сумма цифр является чётным числом.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
djokerzcoziirem9
26.05.2020 00:11

var

  i1, i2, i3: 1..9;  //Цифры трехзначного числа

  i, n: integer;  //n - количество трехзначных чисел, у которых ...

 

begin

  n:= 0;  //Обнуляем счетчик

  for i:= 100 to 999 do  //Перебираем все трехзначные числа и считаем количество

  begin

    i1:= i div 100;

    i2:= (i mod 100) div 10;

    i3:= i mod 10; 

    if (i1 + i2 + i3) mod 2 = 0 then n:= n + 1;

  end;

  writeln('Количество трехзначных чисел, у которых сумма цифр является четным числом равна:  ', n);  //Выводим количество

end.

Если все правильно, отметь решение как лучшее)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота