pirishok
16.08.2021 01:53

Составьте программу, проверяющую, лежит ли точка с заданными координатами вне круга с радиусом r и началом в точке o(a,b) хотя бы примерно

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ktotoipotom
26.05.2020 00:14

var

 x, y, R, Oa, Ob: real;

 

begin

  writeln('Введите радиус окружности R');

  readln(R);

  writeln('Введите координаты центра окружности');

  readln(Oa, Ob);

  writeln('Введите координаты точки');

  readln(x, y);

  if (x > (Oa - R)) and (x < (Oa + R)) and (y  > (Ob - R)) and (y < (Ob + R)) then

    writeln('Точка с заданными координатами лежит внутри круга')

  else

    writeln('Точка с заданными координатами лежит вне круга');

end. 

Если все правильно, отметь решение как лучшее)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота