Войти
Регистрация
Спроси ai-bota
Волвлчлчлч
06.07.2022 23:44
Написать программу на языке си .1. подсчитать количество прописных букв в строке. 2. удалить из строки самое длинное слово.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
ruan
23.03.2020 19:27
Составляющий элемент сложной системы...
Ira200489
22.10.2022 17:27
Информатика 9 классалгоритм с while ...
Raz1elGG
09.01.2023 11:58
Использование идентификатора ID для указания особых элементов WEB-страницы. Создание ссылки на FTP-сервер...
darinchiiik
23.01.2020 07:24
Составить блок-схему, и определить какие значения примут переменные a, b и c в результате выполнения данного фрагмента алгоритма с начальными значениями а=3, b=-1, с=0.для i:=2...
njjjjjjtgl
04.05.2020 04:16
Ребят не втыкаю что тут, да и какИНФОРМАТИКА, 7 КЛАСС...
Sdkhkazb
07.06.2021 06:50
Сканируется цветное изображение размером 27,94×27,94 см. Разрешающая сканера — 600×1200 dpi, глубина цвета — 8 бита. Какой информационный объём будет иметь полученный графический...
Karamelka659
27.10.2020 15:51
с информатикой, нужен алгоритм с while...
Raydi1337
14.01.2022 06:46
Задан массив: x: array [1..n] of integer. какое условие надо поставить в фрагменте программы вместо многоточия, чтобы найти количество положительных элементов массива, которые...
Djessika24
20.01.2021 19:05
Решите 3 последние задачи вместе с дано...
Zeka211
12.07.2020 19:27
Стандартным приложением Windows НЕ является …БлокнотПроводникКорзина...
Ответ:
he11sp0re
19.07.2020 19:39
Написать програму которая считывает текст с клавиатуры, находит самое длинное число и определяет, сколько раз оно встретилось в тексте.
Код C++
#include <conio.h>
#include <stdio.h>
#include <string.h>
#include <iostream.h>
void main();
{clrscr();
char s[50];
char s1{}=" ";
char *p;
char *q;
char e[50];
int g,a;
cout<<"vvedite tekst:"<<endl<<endl;
gets(s);
p=strtok(s,s1);
while(p)
{if(*p==' ')
p=strtok(s,s1);
g=strlen(p);
cout<<endl<<g<<endl;
if(a<g)
{a=g;
*e=*p;
}
p=strtok(NULL,s1);
}
puts(e);
cout<<endl<<e;
getch();
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота