фирдавс6
27.02.2021 20:02

Написать программу: даны длины сторон треугольника a,b,c. является ли он прямоугольным?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ланка30
19.07.2020 19:28
Var a,b,c,t:real;
begin
readln(a,b,c);
if b>a then begin
  t:=a;
  a:=b;
  b:=t;
end;
if c>a then begin
  t:=a;
  a:=c;
  c:=t;
end;
if (a*a=b*b+c*c) then writeln('Треугольник прямоугольный') else writeln('Треугольник не прямоугольный');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота