tyupina2018
22.12.2020 03:38

Дан целочисленный массив из 31 элемента, элементы массива могут принимать значения от -20 до 20. написать программу, которая выводит среднюю температуру среди дней, когда была оттепель.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
сергоо16
02.10.2020 09:52
Var a,b,i:integer;
n:real;
mass:array[1..31] of integer;
begin
for i:=1 to 31 do begin
mass[i]:=random(40)-20;
if mass[i]>0 then begin
b:=b+1;
a:=a+mass[i];
end;
end;
writeln('Полученные значения');
for i:=1 to 31 do
write(mass[i]:4);
n:=a/b;
writeln;
writeln('Средняя температура равна ',n:3:1);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота