4нцяулчанняашя
07.01.2023 23:59

Написать программу в паскале. по заданному числу n определите знак числа. формат входных данных: во входном файле input.txt записано одно целое число n (-10000< =n< =10000) формат выходных данных: если заданное число положительное, то в выходной файл output. txt выведите квадрат этого числа. если заданное число отрицательное, то вывелите модуль этого числа. если же заданное число - нуль , то и вывести надо нуль. примеры: input.txt output.txt 5 25 -5 5 0 0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nastya080503
19.07.2020 15:23
Это если алгоритм выполнить дословно:

var
  f1, f2: Text;
  n: integer;

begin
  Assign(f1, 'input.txt'); Reset(f1);
  Assign(f2, 'output.txt'); Rewrite(f2);
  Readln(f1, n);
  if n < 0 then Writeln(f2, abs(n))
  else
  if n = 0 then Writeln(f2, 0)
  else Writeln(f2, sqr(n));
  Close(f1); Close(f2)
end.

А это, если учесть, что модуль нуля равен нулю:

var
  f1, f2: Text;
  n: integer;

begin
  Assign(f1, 'input.txt'); Reset(f1);
  Assign(f2, 'output.txt'); Rewrite(f2);
  Readln(f1, n);
  if n <= 0 then Writeln(f2, abs(n))
  else Writeln(f2, sqr(n));
  Close(f1); Close(f2)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота