sofia2004417
15.04.2022 02:27

Напишите программу для решения следующей . ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. найдите среднюю температуру за время наблюдения. если количество дней, когда температура поднималась выше нуля градусов, не менее 5, выведите yes, иначе выведите no. программа получает на вход количество дней, в течение которых проводилось наблюдение n (1 ≤ n ≤ 31), затем для каждого дня вводится температура.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
milkiweika123
02.10.2020 09:36
Var N,i,k,z:integer;   
      s:real;
begin
s:=0;
k:=0; 
repeat 
    write('Введите кол-во дней : ');  
    readln(N); 
until (N>=1) and (N<=31); {проверка на верное количество дней}
for i:=1 to N do 
begin 
    write ('Введите значение температуры в ',i,' день : '); 
    readln(z); 
    s:=s+z; 
    if z>0 then k:=k+1; 
end;
s:=s/N;
writeln('Средняя температура = ',s);
if k>=5 then writeln('YES') else writeln('NO');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота