Акбота1ю
19.02.2022 15:45

Составить программу. дано натуральное число n. подсчитать количество цифр этого числа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
loser80
19.07.2020 13:23
Var
  n: longint;
  s: string;
  k: byte;

begin
  Write('Введите натуральное число '); Readln(n);
  { Преобразуем число к строке, убрав знак (мало ли...) }
  Str(abs(n), s);
  { Выведем длину полученной строки }
  Writeln('Количество цифр в числе равно ', Length(s))
end.

Тестовое решение:
Введите натуральное число 164275353
Количество цифр в числе равно 9
0,0(0 оценок)
Ответ:
yuliadruzhko
19.07.2020 13:23
Program chisla;
uses crt;
var a,b,c: integer;
begin
writeln('Введите натуральное число: ');
readln(a);
b:=a;
c:=0;
while b <>0 do
begin
c:=c+1;
b:= b div 10;
end;
writeln('B числе ',a,' - ',c, ' цифр');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота