liliya15nafikova
21.10.2021 00:01

Дано трехзначное число.найти сумму цифр числа.(написать программу на языке паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Anastasii777
19.07.2020 12:17
Люблю работать в Паскале)
0,0(0 оценок)
Ответ:
рамиля28
19.07.2020 12:17
Program chisla;
uses crt;
var a,b,c,d : integer;
begin
Writeln('Введите трехзначное число: ');
Readln(a);
if (a<100) or (a>999) then writeln('Введено не трехзначное число')
else
begin
b:=a div 100;
c:=(a-(b*100)) div 10;
d:=a-(b*100)-(c*10);
Writeln('Сумма цифр этого числа равна ',b+c+d);
end
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота