anastasialishcnastya
21.03.2021 15:15

Нужна : составить программу по которой компьютер угадает число введеное с клавиатуры (с repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
2810vika
25.05.2020 23:17

var x,y,a:integer;
c:boolean;
begin
readln(x); {считываем}

a:=1;
repeat

writeln(a,' попытка выбор компьютера пал на - ');
y:=random(x)+1; {задаем промежуток рандомом}

write(y);
if x=y {сравниваем} then c:=true; {выходим из цикла в случае успеха}
until c; {если с=true тогда выход из цикла, иначе крутимся дальше}

writeln('Компьютер сделал ',a,' попыток.');
end.


Более доработанная и понятная, если возникают какие-то вопросы - пиши в личку.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота