СофияСтепанова
06.01.2022 16:59

Надо написать программу определяющую характеристику произвольного числа введённого через клавиатуру.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tunekoff228
25.05.2020 22:53

var a:integer;

begin

write('Введите произвольное число'); readln(а);

if a = 0 then begin

writeln ('Введен нуль');

exit;

end;

if а > 0 then writeln ('Число положительное');

else writeln ('Число отрицательное');

if a mod 2 = 0 then writeln('Число четное');

if a mod 3 = 0 then writeln('Число кратно 3');

if a mod 5 = 0 then writeln('Число кратно 5');

if a mod 7 = 0 then writeln('Число кратно 7');

if a mod 9 = 0 then writeln('Число кратно 9');

if a mod 10 = 0 then writeln('Число кратно 10');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота