1)составить программу для нахождения суммы первых n натуральных чисел.(n вводим с клавиатуры). 2) написать программу, которая выводит таблицу квадратов первых пяти целых положительных нечетных чисел в порядке убывания. большое ! )
begin Write('Введите натуральное число: '); Readln(n); s := ((n + 1) * n) div 2; { сумма арифметической прогрессии } Writeln('Сумма натуральных чисел от 1 до ', n, ' равна ', s) end.
Результат выполнения программы: Введите натуральное число: 10 Сумма натуральных чисел от 1 до 10 равна 55
var i: integer;
begin Writeln('Квадраты первых пяти нечетных натуральных чисел'); i := 5 * 2 - 1; while i > 0 do begin Writeln(i:2, sqr(i):5); i := i - 2 end end.
Результат выполнения программы: Квадраты первых пяти нечетных натуральных чисел 9 81 7 49 5 25 3 9 1 1
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку