Ден2811
02.04.2021 07:43

Составьте программу для вычисления значения выражения x в степени n + y в степени m. значения x,y,n,m > 0 вводятся с клавиатуры. примечание: чтобы возвести число в n-ную степень, надо его умножить само на себя n раз.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
popovvovapo
19.07.2020 09:00
Begin
var x, y, n, m: integer;
Readln(x, y, n, m);
Assert((x > 0) and (y > 0) and (n > 0) and (m > 0));
var upstep: integer := n + y;
for var i := 2 to m do
upstep *= (n + y);
var lowstep := x;
for var j := 2 to upstep do
lowstep *= x;
Writeln(lowstep);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота