18фо
01.12.2020 23:55

Составьте программу( на паскале) заполнения массива из 100 чисел,случайными значенииями из диапазона от -20 до 20 подсчитайте в этом массиве количество,положительных и отрицательных значений

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kotik12345566
19.07.2020 08:01
Const N = 100;
var a: array[1..n] of integer; i, countp, counts, countz:integer;
begin
for i := 1 to n do begin
a[i] := random( -20, 20 );
write ( a[i], ' ' );
if a[i] > 0 then inc(countp);
if a[i] < 0 then inc(counts);
if a[i] = 0 then inc(countz);
end;
writeln();
writeln('Количество положительных чисел: ', countp);
writeln('Количество отрицательных чисел: ', counts);
writeln('Количество нулей: ', countz); // выводим количество нулей (для проверки, что в сумме у нас 100 элементов)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота