денисдениска
28.01.2023 15:24

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно четное. была написана следующая программа: var a, b: integer; begin readln(a, b); a : = a mod 2; if a > 0 then b : = b mod 2; if b > 0 then writeln ('четных чисел нет') else writeln ('четное число есть'); end. известно, что программа написана с ошибками. последовательно выполните три : укажите, как, по вашему мнению, нужно доработать программу (не используя слож-ные условия), чтобы не было случаев ее неправильной работы;

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
елізабет2002
02.10.2020 08:47
Var
a,b:integer;
Begin
readln(a,b);
if a mod 2= 0 then writeln('есть чётное')
else if b mod 2=0 then writeln('есть чётное') 
else writeln('Нет чётных);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота