Напишите программу на языке паскаль, распознающую по длинам сторон среди всех треугольников прямоугольный. если они прямоугольные, то должно выводится сообщение 'это прямоугольный треугольник'.
Var a,b,c:real; begin read(a, b, c); if ((a=sqrt(sqr(b)+sqr(c)))or(b=sqrt(sqr(a)+sqr(c)))or(c=sqrt(sqr(a)+sqr(bthen write('Это прямоугольный треугольник') else write('Это не прямоугольный треугольник') end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку