kseniy124321
04.09.2022 04:12

Решить в паскале с использованием цикла с ! числа фибоначчи (fn) определяются формулами: f0=f1=1; fn=fn-1+fn-2 при n=2, составить программу: а) определения f - 40-е число фибоначчи; б) поиска f - первого числа фибоначчи, большего m (m> 1); в) вычисления s - суммы всех чисел фибоначчи, которые не превосходят 1000

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
terehovakira
25.05.2020 21:56

// A)

begin

 var f1 := BigInteger(1);

 var f2 := BigInteger(1);

 var Count := 2;

 

 repeat

   var f := BigInteger(f1 + f2);

   f1 := f2;

   f2 := f;

   Count += 1

 until Count = 40;

 

 Write(f2)

end.

// B)

begin

 var f1 := BigInteger(1);

 var f2 := BigInteger(1);

 var m := ReadlnInteger();

 

 repeat

   var f := BigInteger(f1 + f2);

   f1 := f2;

   f2 := f;

 until f2 > m;

 

 Write(f2)

end.

// C)

begin

 var f1 := BigInteger(1);

 var f2 := BigInteger(1);

 var S := f1;

 

 repeat

   S += f2;

   var f := BigInteger(f1 + f2);

   f1 := f2;

   f2 := f;

 until f2 >= 1000;

 

 Write(S)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота