1235124
13.06.2020 15:35

Что будет выведено на экран в результате выполнения программы, если в ответ на приглашение введено слово cat? var x,y: char; begin writeln (‘введите несколько символов’); readln (x,y); writeln (x,y,y); end. а) cat б) ccc в) caa г) ca 2.как будут выведены значения переменных а и в операторами writeln (a); writeln (b); а) через строку; б) через пробел в) в столбик г) слитно 3.какой тип данных в языке pascal предназначен для хранения символьной информации? а) real б) integer в) char г) byte 4. есть ли ошибки в записи команды: readln (введи радиус, r) а) нет ошибок б) пояснительный текст не заключен в апострофы в) пояснительный текст не нужен г) лишнее слово “введи” 5. при выполнении операции присваивания символа переменной а) символ заключается в кавычки б) символ записывается через пробел от знака присваивания в) символ заключается в апострофы г) символ записывается в скобках по теме «обработка текстовых данных» 1. составить программу подсчета количества вхождений буквы “а” в заданном тексте. 2. даны две строки, выяснить ли их длины.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Umarinavitalevna
17.07.2020 15:17
1 - в) caa
2 - в) в столбик
3 - в) char
4 - в) пояснительный текст не нужен
5 - в) символ заключается в апострофы

1)
Var s1: string;
i,a:integer;
Begin
Writeln ('введите текст');
Readln (s1);
for i:=1 to length(s1) do
if (s1[i]='а')or(s1[i]='a') then a:=a+1;
writeln('количество букв а в тексте: ',a);
End.

2)
Var s1,s2: string;
Begin
Writeln ('введите первую строку');
Readln (s1);
Writeln ('введите вторую строку');
Readln (s2);
if length(s1)=length(s2) then writeln('длины строк совпадают')
else writeln('длины строк не совпадают')
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота