bazhin789bazowzpsb
16.03.2023 02:49

Написать программу генерирующую и выводящую на экран стозначное целое число.определить делится ли данное стозначное число на 3 или 9

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zaharkakorsunov
25.05.2020 21:54

Program zadacha;

Var x:integer;

Begin

  Randomize;

  x:=random(9999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999)+1000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000;

  If (x mod 3=0) then begin

    If (x mod 9=0) then writeln('Делится на 3 и на 9);

  End;

  If (x mod 3=0) then begin

    If (x mod 9>0) then writeln('Делится только на 3);

  End;

  If (x mod 9=0) then begin

    If(x mod 3>0) then writeln('Делится только на 9);

  End; 

End.

 

 

P.S. Вы уверены, что СТОзначное число?

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота