Вова21123
13.10.2022 18:58

Составить программу для нахождения площади ромба по стороне а и острому углу f (угол предварительно переведите в радианы t = f · 3,14 : 180) по формуле s = a 2 sin t

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Binnez
17.07.2020 11:51
Var
  a, f, t, S: real;

begin
  Write('Введите длину стороны ромба: '); Readln(a);
  Write('Введите величину острого угла ромба в градусах: '); Readln(f);
  t := f * pi / 180;
  S := sqr(a) * sin(t);
  Writeln('Площадь ромба равна ', S, ' кв.ед.')
end.

Тестовое решение:
Введите длину стороны ромба: 14.3
Введите величину острого угла ромба в градусах: 58.7
Площадь ромба равна 174.728286173858 кв.ед.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота