Funik228
31.07.2022 08:41

Напишите программу, которая по заданному натуральному n печатает первые n чисел последовательности 1, 2, 4, 8, 16, 32. в первой строке содержится n (1 ≤ n ≤ 50) – количество чисел. вывести первые n чисел прогрессии со знаменателем 2 и первым членом 1. с++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Fulfevgen
17.07.2020 10:51
#include <stdio.h>

int main()
{
int n, i;
scanf("%d", &n);
if (n>=1&&n<=50)
{
for (i=1; i<=n;i*=2){
printf("%d ", i); }
}
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота