яна7933
13.05.2023 01:54

Не могу написать программу на языке паскаль. даны три целых двузначных числа. из наибольшего из них вычесть наименьшее и сравнить результат с оставшимся числом. если полученное число будет больше вывести yes в противном случае no.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dany20skribka
02.10.2020 07:31
Var
  a,b,c,max,mid,min,t:integer;
begin
  Writeln('Введите через пробел три целых двухзначных числа');
  Readln(a,b,c);
  if a>b then begin max:=a; min:=b end
  else begin max:=b; min:=a end;
  if max<c then begin mid:=max; max:=c end
  else mid:=c;
  if min>mid then begin t:=mid; mid:=min; min:=t end;
  if (max-min)>mid then Writeln('YES')
  else Writeln('NO')
end.

Тестовое решение:
Введите через пробел три целых двухзначных числа
37 93 74
NO
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота