Wlig123
01.07.2020 18:47

Добрый вечер. , написать программу (на pascal) для решения квадратного уравнения.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Fits97
17.07.2020 00:00
Var a,b,c,d,x1,x2:real;
begin
read(a,b,c);
d:=sqr(b)-4*a*c;
if(d>0)then begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
writeln('x1=',x1:3:5,' x2=',x2:3:5);
end else if(d=0)then begin x1:=-b/(2*a); writeln(x1:5);end
else writeln('Нет корней. Дискриминант меньше 0');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота