visokolova
11.02.2023 00:47

Нужно составить программу(ну как всегда varbegan ну и т.д.) дана дробь a/b. требуется ее сократить. то есть записать это же число в виде c/d, где c — целое число, d — натуральное число и d минимальное возможное.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tupayadaria
25.05.2020 21:08

var i,a,b,a1:integer;
begin
readln(a,b);
a1:=a;
for i:=1 to a1 do begin
if (a mod i=0) and (b mod i=0) then begin
a:=a div i;
b:=b div i;
end;
end;
writeln('c=',a,' d=',b);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота