Yanuska224
24.02.2023 04:43

Написать программу и доказать её работо условие : найти и вывести на экран сумму нечётных элементов массива и количество отрицательных. pascal abc полное решение , заранее )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Danil1214d
16.07.2020 15:19
Program z8;
uses crt;
var a:array[1..259] of shortint;
i,k,n:byte;
s:integer;
begin
clrscr;
randomize;
write('Vvedi razmernost massiva=');
readln(n);
for i:=1 to n do begin
a[i]:=random(100--100+1)+-100;
write(a[i]:4);
if a[i]<0 then
s:=s+a[i];
if odd(a[i]) then
k:=k+1;
end;
writeln;
writeln('Сумма отрицательных элементов равна ',s);
writeln('Кол-во нечётных элементов равно ',k);
readkey
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота