Оксана0990
02.03.2023 11:08

Составить программу вычисление площади треугольника по трём сторонам. s=1\2aha

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KalinaNatalia
16.07.2020 11:45
По трем сторонам - формула Герона.
var a,b,c,p:real;
begin
write('Введите стороны: ');
readln(a,b,c);
p := (a + b + c) / 2;
writeln('Площадь равна ', sqrt(p * (p - a) * (p - b) * (p - c)):9:4);
end.

А через основание и высоту (твоя формула):
var a,h:real;
begin
write('Введите длину основания и высоты, проведенной к нему: ');
readln(a, h);
writeln('Площадь равна: ', (a * h) / 2:9:4);

:9:4 -- это такой оператор, который выводит число в формате с фиксированной точкой и 4 знаками после запятой.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота