sumbaeva20161
05.05.2021 09:12

Решить по паскалю: 1. модифицируйте предыдущий пример, так чтобы программа определяла максимальный и минимальный элемент массива 2. напишите программу, которая бы определяла среднее арифметическое значение элементов массива (вещественная величина типа real) начало: var a: array[1..10] of integer; i: integer; begin а как дальше? предыдущий пример: var a: array[1..10] of integer; i: integer; begin randomize; for i: =1 to 10 do begina[i]: =random(40)-20; end; for i: =1write(a[i]: 4); end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zadyriakaartem
16.07.2020 10:09
Const
  n = 10;

var
  a: array[1..n] of integer;
  i, k, min, max: integer;

begin
  randomize;
  min := 100; max := -100;
  Writeln('исходный массив');
  for i := 1 to n do
  begin
    k := random(40) - 20;
    a[i] := n;
    if max < k then max := k
    else if min > k then min := k;
    Write(k, ' ')
  end;
  Writeln;
  Writeln('min=', min, ', max=', max)
end.

Тестовое решение:
исходный массив
-8 3 19 -14 19 13 -17 -2 8 8
min=-17, max=19


const
  n = 10;

var
  a: array[1..n] of integer;
  i, k, s: integer;

begin
  randomize;
  s := 0;
  Writeln('исходный массив');
  for i := 1 to n do
  begin
    k := random(40) - 20;
    a[i] := n; s := s + k;
    Write(k, ' ')
  end;
  Writeln;
  Writeln('Среднее арифметическое равно ', s / k)
end.

Тестовое решение:
исходный массив
19 11 -1 1 -4 -6 -2 18 3 8
Среднее арифметическое равно 5.875
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота