Dashasdh
14.03.2023 10:15

Нужно написать программу, которая печатает true, если точка (x; y) принадлежит закрашенной области. pascale.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Мария1111121
16.07.2020 01:15

var

 x, y: real;

begin

 read(x, y);

 if y <= -x + 4) and (y >= -x + 2) and (x >= 0) and (y >= 0))  

 or ((y <= x + 4) and (y >= x + 2) and (x <= 0) and (y >= 0))  

 or ((y >= -x - 4) and (y <= -x - 2)) and (x <= 0) and (y <= 0)))then

   write('true');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота