evgen22region
14.11.2021 08:26

Написать программу, тестирующую знания по астрономии. вопросов должно быть 10. вариантов ответа 3, выбор ответа однозначный. по окончании теста должно быть выведено количество правильных ответов. использовать графические модули для разработки интерфейса.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikasuper09
06.11.2022 05:12
Const
    handsfree = true;

var
    a: array[1..100] of real;
    i, n: integer;
    min, max: real;
    k: integer;

begin
    {ввод массива}
    if handsfree then
        n := random(20) + 5
    else begin
        write('n = ');
        readln(n);
    end;
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100);
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
    
    {подсчет элементов}
    k := 0;
    for i := 1 to n do
        if a[i] > 5 then k := k + 1;
    writeln(k);
end.
0,0(0 оценок)
Ответ:
maytanya47
12.10.2021 11:55
Сначала немного теории.
--> - импликация, следование
Таблица истинности импликации

x1 x2 r
0   0  1
0  1   1
1  0   0
1  1   1
Общее правило: если x1<=x2, тогда правда, в остальных случаях ложь.
^ - Конъюнкция, логическое И
Таблица истинности конъюнкции
x1 x2 r
0   0  0
0   1 0
1   0  0
1   1  1
Общее правило: если x1 или x2 = 0, тогда ложь. x1=x2=1, только тогда правда.

(первая буква имени согласная ---> вторая буква имени согласная)^ четвертая буква имени согласная 
1) Лариса 
2) Сергей 
3) Геннадий 
4)Елена

Теперь по вариантам:
1) Лариса 
Получается (1-->0)^0=0^0=0, не подходит
2) Сергей 
(1-->0)^1=0^1=0, не подходит
3) Геннадий
(1-->0)^1=0^1=0, не подходит
4) Елена
(0-->1)^1=1^1=1, подходит
ответ: 4) Елена

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота