Happymilks
01.02.2020 18:36

Задано трёхзначное число составьте программу которая определяет равны ли в нём произведение первой и третьей цифры и сумма второй и первой цифры

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lili247
25.05.2020 19:53

Паскаль

 

program m1;
uses crt;
var a,b,c,d:integer;
begin
write('Введите число: '); readln(a); {Задаем число}
b:=a mod 10; {В переменную b заносится значение последней цифры в числе}
a:=a div 10; {Сокращаем переменную до 2 чисел}
c:=a mod 10; {В переменную c заносится значение последней(второй) цифры в числе}
a:=a div 10; {Сокращаем переменную до 2 чисел}
d:=a mod 10; {В переменную d заносится значение первой цифры в числе}
if (d*b = d + c) then writeln('Произведение 1 и 3 цифры и сумма 2 и 1 цифр равны!')
else writeln('Произведение 2 и 3 цифры и сумма 1 и 1 цифры не равны!');
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота