Kmamsmajfkf
21.12.2020 12:41

Язык си. написать программу заполнения односвязного списка значениями и вывода этих значений. , .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tumenka140
02.10.2020 05:40
выбирай 

#include <stdio.h>
#include <stdlib.h>  

struct LIST {  
  int number;  
  struct LIST *next; };
  //
void Push(struct LIST** list, int number) {    
struct LIST* node = malloc(sizeof(struct LIST));  
  node->number = number;    
 node->next = *list;  
  *list = node; }
//
void Print(const struct LIST* list) {  
   if (list) {      
   Print(list->next);    
     printf("%d ", list->number);     } }
//  
int main() {  
  int i = 10;  
  struct LIST* list = NULL;
      while (i--) {      
  Push(&list, i + 1);     }  
//---(это разделение разных программ)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота