livi9
29.02.2020 09:49

Cи написать программу, считывающую с клавиатуры 32-битное беззнаковое число n, числа a и b и выводящую на экран число, равное исходному n, но с установленным битом номер a и снятым битом номер b

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mn197
02.10.2020 05:36
#include <iostream>
using namespace std;

int main() {
    unsigned int n,a,b;
    cin>>n>>a>>b;
    n&=1<<a;
    n&=(0x)-(1<<b);
    cout<<n;
    return 0;
}
Что-то в этом духе
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота