Написать программу в ! составить процедуру, заменяющую в исходной строке символов все единицы нулями и все нули единицами. замена выполняется, начиная с заданной позиции строки.
Var k:integer; s:string; procedure Zamena(var ss:string; p:integer); var i:integer; begin for i:=p to length(ss) do begin if ss[i]='1' then ss[i]:='0' else if ss[i]='0' then ss[i]:='1'; end; end; begin writeln('Введите строку: '); readln(s); writeln('Введите позицию с которой начинать замену: '); readln(k); Zamena(s,k); writeln('Измененная строка: ',s); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку