Sasha03kms
10.09.2022 01:02

Напишите программу. группа студентов сдает экзамен. оценки формируются случайным образом от 2 до 5. напечатать кол-во полученых двок,трок,четверок,пятерок

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lefuxetube
02.10.2020 05:27
Pascal

const  n = 10; //Кол-во студентов
//можно сделать с вводом с клавиатуры
    var  i,a : integer; 
 o : array[2..5] of integer; 
     begin 
randomize; 
 for i :=2 to  5 do 
  o[i] := 0;   
 
for i := 1 to N do 
 begin 
   a := 2 + random(4); 
   o[a] := o[a] +1; 
  end; 
 for i := 2 to 5 do 
  writeln (i,'=',o[i]); 
 end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота