A8L3E1X
08.06.2020 05:37

Напишите программу формирования и вывода двумерного массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов. два первых элемента задайте с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Danila12312
02.10.2020 05:13
I, j: integer;
a: array [1..100, 1..100] of integer;
begin
readln(a[1][1], a[1][2]);
for i := 3 to 30 do
  a[1][i] := a[1][i - 1] + a[1][i -2];
for i := 2 to 30 do
  for j := 1 to 30 do
begin
  if (j > 2) then
   a[i][j] := a[i][j - 1] + a[i][j - 2]
else
if (j = 2) then
 a[i][j] := a[i][1] + a[i - 1][30]
else
a[i][j] := a[i - 1][30] + a[i - 1][29];
end;

for i := 1 to 30 do
begin
for j := 1 to 30 do
 write(a[i][j],' ')
writeln;
end;
end.
Вот,  сорри если что пишу без компилятора
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота