Мамкинс
14.07.2021 11:54

Pascal авс - написать программу, ! для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · если все числа не превышают 30, то выведите их удвоенное произведение. · если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в десять раз. · если выполняются одновременно два перечисленных выше условия, то выведите эти числа без изменения. · иначе, выведите разность первого и последнего чисел. составьте соответствующие отладочные примеры и проверьте работу каждой программы. заранее .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
teddy33
02.10.2020 05:10
Var   
a,b,c,d,p : integer;
    r : real;
begin
readln (a,b,c,d);
p := 0;
if (a<=30) and (b<=30) and (c<=30) and (d<=30) then
      begin     
p := p +1;     
 r:= a*b*c*d*2;
      end;
if d mod 2 = 0 then
    begin   
 r := a*b/10;   
 p := p + 1;   
end
;case p of
0 : writeln (a-d);  //Как я понял иначе (все условия не выполняются)
1 : writeln (r);
2 : writeln (a,' ',b,' ',c,' ',d); 
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота