switt1q
07.05.2023 13:39

Написать программу на паскале, используя вместо for - while. ! 1. напишите программу, которая в последовательности из 12 натуральных чисел определяет минимальное чётное число. программа получает на вход натуральные числа. в последовательности всегда имеется чётное число. введённые числа не превышают 30 000. программа должна вывести одно число – минимальное чётное число. 2. напишите программу, которая в последовательности из 12 натуральных чисел определяет максимальное число, оканчивающееся на 2. программа получает на вход натуральные числа. введённые числа не превышают30 000. программа должна вывести одно число – максимальное число, оканчивающееся на 2.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Киря0001
15.07.2020 16:27
1) 
 var
    a ,i,min: integer;
begin
min := 30000;
 i := 0;
 while i <> 12 do
  begin
   readln(a);
   if (a<min) and (a mod 2 = 0) then
    min := a;
   i := i +1;
  end;
writeln (min);
end.

2)
 var   
a ,i,max: integer;
begin
max := 0;  i := 0; 
while i <> 12 do 
begin   
readln(a);   
if (a>max) and (a mod 10 = 2) then   
max := a;   
i := i +1; 
end;
writeln (max);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота