toshaantoshai
21.09.2020 19:11

Дана строка. среди символов встречаются цифры. написать программу, вычисляющую сумму всех цифр

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
рустамммм
15.07.2020 11:57
Var
  digits: set of '0'..'9';
  s: string;
  i, p, d, err: integer;

begin
  digits := ['0'..'9'];
  Write('Введите строку: '); Readln(s);
  p := 0;
  for i := 1 to Length(s) do
    if (s[i] in digits) then
    begin Val(s[i], d, err); p := p + d end;
  Writeln('Сумма цифр равна ', p)
end.

Тестовое решение:
Введите строку: Сегодня 17 декабря 2014г. Находим сумму 7 цифр их этой строки.
Сумма цифр равна 22
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота