AnnaIzotova53
21.09.2020 19:11

Составить программу подсчитывающую сколько дней в январе было с температурой выше, ниже и равной средней температуре месяца

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KitoKota
15.07.2020 11:56
Var 
m: array [1..31] of integer; //заполненный массив 
sr: real;  //средняя сумма 
sum: integer; //сумма всех элементов 
i: integer;  
a: integer;//значений выше 
b: integer;//значений ниже 
c: integer;//равных среднему 
begin 
 for i := 1 to 31 do   
sum := sum + m[i]; 
sr := sum / 31; 
for i := 1 to 31 do   
if m[i] > sr then     
 a := a + 1   
else if m[i] < sr then     
b := b + 1   
else c := c + 1; 
writeln(a); 
writeln(b); 
 writeln(c);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота