megolodoon
15.12.2020 13:11

Заполнить массив из 10 элементов случайными числами в интервале [- и выполнить инверсию отдельно для 1 и 2 половин массива. пример: исходный массив: 4 -5 3 10 -4 -6 8 -10 1 0 -4 10 3 -5 4 0 1 -10 8 -6

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nezervillager
15.07.2020 08:56
Ну почему,когда просят написать программу никто никогда не указывает язык программирования.я напишу на языке паскаль с входным и выходным файлом,но если это не тот язык,твоя проблема.(сообщения в фигурных скобках,это комментарии,просто для пояснение,можешь удалить их)

program p1;
const n=10;
var a : array[1..n] of integer;
i,b,c:integer;
begin 
randomize; 
assign(input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);

for i:=1 to n do {Заполнение исходного массива}   
a[i]:=random(21)-10;
  
for i:=1 to n do {Вывод исходного массива(можно удалить эти строчки)}
write(a[i]:4);

c:=0; {Инверсия массива} 
for i:=1 to 2 do  begin   
b:=a[i];   
a[i]:=a[5-c];   
a[5-c]:=b;   
c:=c+1; 
end; 
c:=0; 
for i:=6 to 8 do 
begin   
b:=a[i];   
a[i]:=a[10-c];   
a[10-c]:=b;   
c:=c+1; 
end; 
writeln;
  
for i:=1 to n do {Вывод инверсированого массива} 
write(a[i]:4);

close(input);
close(output);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота