Написать программу в ! ! дана действительная матрица размера m x n. найти значение наибольшего по модулю элемента матрицы, а так же определить есть ли в матрице хотя бы один простой элемент.
Program matr; uses crt; const m=(число); n=(число); var a:array[1..m,1..n] of integer; i, j:integer; max:real; k:boolean;
function prost(x:integer):boolean; begin prost:=false; if x>0 then if (x=1) or (x=2) then prost:=true else for i:=2 to x-1 do if mod(x, i) =0 then prost:=true; end;
begin clr scr;
for i:=1 to m do begin for j:=1 to n do begin write(' a[i,j] = '); read(a[i, j]) end; writeln end;
max:=abs a[1,1]; k:=false; for i:=1 to m do for j:=1 to n do begin if abs(a[i, j]) > abs(max) then max:= a[i, j]; if prost(a[i, j]) then k:=true end; writeln('Максимальный по модулю элемент равен ', max); if k then wrteln('Матрица содержит хотя бы один простой элемент') else writeln('Матрица не содержит простых элементов'); readln end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку