Kirra24
06.05.2023 20:58

Информатика 9 класс. составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов, которые больше своего соседа справа. пример вывода: исходный массив: 10 2 4 1 3 5 7 8 2 7 количество элементов, которые больше своего соседа справа=3 буду

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Stasya1985
02.10.2020 04:13
Const   N=10;
var   a:array [1..N] of integer;   
      k,i:integer;
begin 
randomize; 
for i:=1 to N do  
    begin 
    a[i]:=random(10)+1; 
    write (a[i], ' '); 
end; 
for i:=1 to N-1 do  
   if a[i]>a[i+1] then k:=k+1;  
writeln('k= ', k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота